27 mar. 2009

P'habernos matao. Volviéndome loco con Windows

Una de las varias razones por las cuales uso Windows XP en el ordenador sobremesa, a pesar de ser un sistema operativo antiguo es que, aunque tiene más vicios que una puerta vieja, me los conozco todos. Me siento confiado y seguro, ya que, tras tantas horas pegándome con él, pocas veces tengo la sensación de perder el control. El otro día me enfrenté a una situación relativamente común (un cuelgue) que solucioné rápidamente con un botonazo y reiniciando. Al reiniciar, me topé con otro problema que también sabía resolver; Al arrancar, Windows no mostraba ni los iconos del escritorio, ni la barra de tareas. Sólo el puntero del ratón y la foto (preciosa) de fondo. Como digo, esto suele ser un cuelgue del proceso explorer.exe que es el Windows Explorer (no confundir con Internet Explorer), y que es el proceso del sistema que, entre otras cosas, mantiene la parte visual de Windows. Esto suele solucionarse abriendo el Administrador de Tareas, asegurándonos de que explorer.exe no está activo, si lo está, matando el proceso, y reejecutando explorer.exe en Archivo, ejecutar... etc. Pero esta vez no funcionó. El proceso explorer.exe estaba activo, pero no podía matarlo. Pensé que con otro botonazo se solucionaría, pero estaba equivocado. Volvió a arrancar y se quedó en las mismas. Empecé a sospechar que uno de los discos duros estaba muriendo poco a poco. Sin barra de tareas, sin botón inicio, con la tecla Windows inservible, no había forma de sacar un simple explorador de windows. Se me ocurrió abrir un bloc de notas, (archivo, ejecutar... notepad.exe) y desde el cuadro "abrir" del Bloc de notas, explorar el sistema. Y desde allí, pude programar una comprobación de disco para cada disco (son seis). De nuevo reinicio. El escaneo de todos los discos duró toda una noche. Cuando pensé que ya estaba todo solucionado, y me las prometía tan felices, y volví a arrancar el sistema, el problema seguía ahí, y la cosa parecía que empeoraba. Ya no funcionaba el truco del notepad.exe.

Empecé a sospechar que era debido a la memoria, ya que los discos parecían estar bien. De modo que empecé a hacer distintas pruebas con los cuatro módulos de memoria para detectar el que estaba erróneo. En una de esas, el sistema arrancó, pero me saltó la ventana con un error:

no disk
Exception Processing Message c0000013 Parameters 75b6bf9c 4 75b6bf9


Yo no entendía nada. A juzgar por ese mensaje, el problema era de disco y no de memoria como había pensado a la desesperada. Y tras esta reflexión, volvió a quedarse colgado. Volví a reiniciar, y de nuevo no tenía nada más que la foto de fondo. Entonces se me ocurrió abrir el visor de eventos de Windows (eventvwr.exe). Si había dado este error, habría dejado alguna traza. Y allí estaba. No una, sino montones de ellas desde hacía días, muchas de ellas con origen "disk". Abrí uno de los eventos y el mensaje era "Error detectado en el dispositivo \Device\Harddisk5\D durante una operación de paginación." Pero no tenía forma de ver el \Device\Harddisk5\ si no podía abrir ningún explorador. Abrí una consola (mmc.exe) y abrí el compmgmt.msc, la plantilla de consola del Administrador de equipos. Desde allí intenté arrancar el Administrador de discos, pero se quedaba colgado. Parecía claro que uno de los discos estaba dando problemas, aunque todos ellos habían sido escaneados y no habían dado problemas. Los desconecté todos menos el de arranque y la cosa seguía igual. De modo que el disco maldito parecía ser el de arranque, un Samsung de 320 GiB (298 GB). Me empecé a hacer a la idea. Afortunadamente no tenía información sensible en él, sólo el sistema operativo y los programas. Si finalmente perecía, no tendría más que sustituírlo por otro, y entregarme a la odiosa tarea de reinstalar todo. Dentro de lo malo...

Pero no me quería rendir aún, así que intenté usar el comando diskpart de la consola de recuperación de Windows, para verificar que efectivamente era ese disco el famoso Device\Harddisk5. Y la consola de recuperación me dio la primera pista. Al arrancarla (desde el CD de instalación de Windows XP), hace una breve comprobación de todos los discos duros. Y se quedaba bloqueada siempre "comprobando 978 MB del disc..." No tenía ningún disco de 978 MB a no ser que algo estuviera yendo realmente mal en uno de ellos. Tras varios intentos de arranque de la consola de recuperación me di cuenta de lo que era. En el lector de tarjetas había una minúscula xD de 1 GiB (aunque la mentirosa etiqueta pone que es de 1 GB) (vaya, vaya, exactamente 976 MB) Saqué la tarjeta del lector, reinicié y ¡voilá!

¿La explicación? Por algún motivo Windows intentaba hacer alguna operación sobre esa unidad, (supongo que paginación) y al ser muy lenta, daba problemas, o algo así... Vaya usted a saber.

Tiempo total dedicado al problema, 9 horas (sin contar el tiempo desatendido de escaneo). Tiempo dedicado a solucionarlo, los 5 segundos de sacar la tarjeta del lector de tarjetas.

1 comentarios. Deja alguno tú.:

Juan Carlos dijo...

Eso de que los tamaños reales de los discos no coincidan con los tamaños que dicen los fabricantes que tienen es otra manera de que nos levanten los cuartos. Porque dicen que es de 1 giga pero se les olvida que el número mágico es 1024 y van y se lo comen (a su favor, claro) Pero coincido contigo en que más vale XP en mano que VISTA con gafas. Y para más seguridad MAC pero ¿quién sabe manejarlo bien?

Related Posts Plugin for WordPress, Blogger...